History | Log In     View a printable version of the current page.  
Issue Details (XML | Word | Printable)

Key: QB-3344
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Robin Shen
Reporter: CM-ATPCO
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
QuickBuild

Build condition: If changes found in referenced repositories is not working as expected

Created: 19/Feb/19 09:03 PM   Updated: 22/Feb/19 01:41 PM
Component/s: None
Affects Version/s: 7.0.16
Fix Version/s: None

Original Estimate: Unknown Remaining Estimate: Unknown Time Spent: Unknown
File Attachments: 1. Text File full-log (2).txt (943 kb)
2. PDF File QB_screenshot_1.pdf (34 kb)

Environment: QB production


 Description  « Hide
Build condition: If changes found in referenced repositories is not working as expected

We have set up a periodical schedule to run 5 mins and build condition is set to If changes found in referenced repositories and we have also set Include exclude Path patterns.

We are seeing that this condition is not working as expected. Builds are not triggered with change.

Please advise.

Thanks,

Malini



 All   Comments   Work Log   Change History      Sort Order:
CM-ATPCO [22/Feb/19 01:41 PM]
Thanks much Robin.

Once we made the changes as you mentioned, our schedules are working as expected.

You can close this ticket.


Robin Shen [20/Feb/19 10:01 PM]
Looks like you've prepended the repository name before the include/exclude pattern. Please change it to:
stg/ngp/**

CM-ATPCO [20/Feb/19 04:12 PM]
I am also attaching the screenshot of the QB setting we have for the configuration we are testing

CM-ATPCO [20/Feb/19 04:10 PM]
I have also attached our full server log here around the same time with debug enabled.

I have disabled debug and reset log level to INFO after capturing this log.

CM-ATPCO [20/Feb/19 04:09 PM]
We enabled debug in quickbuild and this is what I found relvant to our config aroun th etime we expected it to kick off a build:

2019-02-20 09:35:35,733 [pool-1-thread-36032] INFO com.pmease.quickbuild.DefaultBuildEngine - Build request has been processed.
2019-02-20 09:35:59,092 [pool-1-thread-36032] DEBUG com.pmease.quickbuild.DefaultBuildEngine - Scheduled time reaches for configuration 'root/Mercury/NGP/Check_existence/Create_Instance/ATPCO_Staging_configurations', checking for schedule random setting...
2019-02-20 09:35:59,092 [pool-1-thread-36032] DEBUG com.pmease.quickbuild.DefaultBuildEngine - Sleep for '40' seconds before triggering configuration 'root/Mercury/NGP/Check_existence/Create_Instance/ATPCO_Staging_configurations...
2019-02-20 09:36:01,091 [qtp2105304404-23] DEBUG com.pmease.quickbuild.model.Configuration - Constucted build option bean:
    groovy:import com.pmease.quickbuild.annotation.*;
    import javax.validation.constraints.*;
    import org.hibernate.validator.constraints.*;
    class BuildVariablePromptBean_11071 {
    public String Branch;
    @Editable(name="Branch", order=10004)
    @NotEmpty
    @Property("Branch")
    public String getBranch() {
    return Branch;
    }
    public void setBranch(String value){
    this.Branch=value;
    }
    }
    return BuildVariablePromptBean_11071;

Robin Shen [19/Feb/19 10:17 PM]
Please enable debug logging in "<QB server dir>/conf/log4j.properties" by changing line "log4j.logger.com.pmease.quickbuild=INFO" as "log4j.logger.com.pmease.quickbuild=DEBUG"


After the change, wait for a minute and reproduce the issue again, QB should print the command being executed as well as the command output around the message I mentioned.

CM-ATPCO [19/Feb/19 10:14 PM]
I have attached the server log from the time with reference to the configuration that was supposed to have triggered.

CM-ATPCO [19/Feb/19 10:00 PM]
(configuration:root/Mercury/TAT/Check_existence/Create_Instance/ATPCO_Staging_configurations, request id:1f557e27-7cba-4b4d-aa4e-7728d6cc871f)
2019-02-19 14:58:32,354 [pool-1-thread-35266] INFO com.pmease.quickbuild.DefaultBuildEngine - Checking build condition on node (address: cmbuild01:4443, ip: 10.16.24.88)...
2019-02-19 14:58:32,356 [pool-1-thread-35280] INFO com.pmease.quickbuild.CheckConditionJob - Taking repository snapshots...
2019-02-19 14:58:32,357 [pool-1-thread-35280] INFO com.pmease.quickbuild.repositorysupport.Repository - Taking snapshot of repository 'Mercury_configurations'...
2019-02-19 14:58:32,357 [pool-1-thread-35280] INFO com.pmease.quickbuild.repositorysupport.Repository - Determining head revision for repository: Mercury_configurations
2019-02-19 14:58:32,950 [pool-1-thread-35280] INFO com.pmease.quickbuild.CheckConditionJob - Evaluating build condition...
2019-02-19 14:58:32,956 [pool-1-thread-35280] INFO com.pmease.quickbuild.repositorysupport.Repository - Getting changes of 'Mercury_configurations' since build 'ATPCO_TAT_staging_configs.01.0.00_int_181115_172935_b49784'...
2019-02-19 14:58:32,957 [pool-1-thread-35280] INFO com.pmease.quickbuild.plugin.scm.helper.ScmCli - Getting changes between 6d232b2cc40ac86589028d79a8d14311ec9646fb - 402420a4a0a57b03ff906c57282e681f78cf0b35
2019-02-19 14:58:33,370 [pool-1-thread-35266] INFO com.pmease.quickbuild.DefaultBuildEngine - Build condition not satisfied, new build won't be generated.

Robin Shen [19/Feb/19 09:39 PM]
Can you please check the server log to see if there is anything like below around the scheduled time:
Build condition not satisfied, new build won't be generated